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This equipment is intended for electrical engineers. If you are not familiar 
with electrical engineering or embedded systems programing, this product 
may not be for you.

This device was developed and tested using a Windows computer. It was not 
tested on Mac, Atlas Scientific does not know if these instructions are 
compatible with a Mac system.

Atlas Scientific does not make consumer electronics.

IP64
(dust and water splash proof)
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Operating principle

Overview

The Wi-Fi Aquaponics kit has been designed to provide the engineer with a simple way of 
remotely monitoring and controlling an aquaponics system's chemistry. Sensor data 
is uploaded to ThingSpeak ™, a free, cloud-based data acquisition and visualization 
platform. The Wi-Fi Aquaponics kit has also been designed to be easily modified by the 
engineer. Feel free to change the sensors or functionality of the device to meet your 
specific needs.

The Wi-Fi Aquaponics kit is controlled using an Adafruit HUZZAH32 as its CPU.  
The HUZZAH is programmed using the Arduino IDE and uses an onboard ESP32 as its 
Wi-Fi transmitter. Adafruit HUZZAH32 datasheet.

CPU

3V GND TXRX

SDASCL

The Wi-Fi Aquaponics kit PCB has 7 sensor ports. Three of the ports are electrically 
isolated. The isolated ports are marked pH, Dissolved Oxygen, and Conductivity. The 
isolated ports are needed to take noise-free electrochemical readings. Because the sensing 
element of a temperature sensor is never in direct contact with the water, electrical isolation 
is not needed for temperature sensing.

Port 5 and 6 are marked Humidity and CO2. The terminal block marked Port 7 has been 
designed to connect one or more dosing pumps to the device. However, the port could 
also be used to connect a gas sensor.

Sensor ports
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https://learn.adafruit.com/adafruit-huzzah32-esp32-feather


The overall design of the PCB is quite simple. The CPU is powered and programmed 
through the panel-mount USB connector. The CPUs USB pin supplies the board's power 
bus with 5V. 

Each of the six main sensor ports have an enable pin, which must be set correctly to power 
the sensor. The enable pins are found here:

PCB
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The first three pins (pH, D.O and Cond) must be set low to power on the sensors.
While the Temp, CO2 and Hum pins must be set high to power on the sensors.

Truth table

Pin

pH EN LOW ON

D.O. EN LOW ON

Cond EN LOW ON

Temp EN

CO2 EN

Hum EN

HIGH

HIGH

HIGH

ON

ON

ON

Sensor PowerState
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Sensor port 7 (the terminal block) does not
have an enable pin and can not be turned off.



The PCB has a built in protocol toggler which can be used to switch each of the sensors 
between I2C/UART modes.

Place an EZO circuit onto 
the I2C/UART switch pins.

The EZO circuit in UART mode... ...is now in I2C mode.

On Board I2C/UART Switch
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Data protocol 
The CPU communicates with all peripheral sensors using the I2C data protocol. All data 
lines are directly connected to the CPUs I2C port. Using a different data protocol with this 
circuit board is not possible.

It is important to keep in mind that all Atlas Scientific components default to UART mode. 
When adding a new Atlas Scientific component to the kit, it must first be put into I2C 
mode. Refer to the component's datasheet for instructions on how to switch it over, or use 
the on board protocol toggler mentioned above.

5 Copyright © Atlas Scientific LLC



Adding more of the same 
sensor or component type
Adding additional components of the same type, such as an additional pH or conductivity 
sensor, is not hard to do. As mentioned above, you must set the device to I2C mode, and 
you must make sure that its I2C address is not the same as the already existing component.

I2C Address
99 (0x63)

I2C Address
100 (0x64)  

I2C Address
102 (0x66)  

I2C Address
99 (0x63)

Conflicting I2C Address

TX R
X

TX R
X

G
N
D

TX R
X

G
N
D

Conductivity

Humidity

TemperatureDissolved OxygenpH

AtlasScientific
Aquaponics Kit

G
N
D

TX R
X

G
N
D

CO2

W
hite

B
lue

B
lue

W
hite

VCC

GND

SDA

SCL

SD
A

SC
L

H
um

 E
N

C
O
2 
E
N

Te
m
p
 E
N

C
o
nd
 E
N

D
.O
. E

N

p
H
 E
N

W
hite

B
lue

RTD

V
C
C

G
N
D

TX R
X

EZO

V
C
C

G
N
D

TX R
X

I2C/UART Switch

This table lists the default I2C address of components commonly added to this kit.

Device Device Device

EZO pH EZO EC EZO CO299 (0x63) 100 (0x64) 105 (0x69)

EZO ORP EZO RTD EZO HUM98 (0x62) 102 (0x66) 111 (0x6F)

EZO DO EZO PMP EZO PMP-L97 (0x61) 103 (0x67) 109 (0x6D)

I2C Address I2C Address I2C Address

6 Copyright © Atlas Scientific LLC



Dosing pump
An optional external dosing pump can be added to the Wi-Fi Aquaponics kit.
Using the SGL-PMP-BX is the simplest way to add on a dosing pump.

A stand-alone EZO-PMP can be used instead of the expansion pump kit; however, you 
must manually put the pump in I2C mode and remove the data cable connector.
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Uploading sensor data 
to the cloud
The Atlas-Scientific Wi-Fi hydroponics kit has been designed to upload sensor data to 
ThingSpeak™, a free, cloud-based data acquisition and visualization platform. You will be 
required to set up a free account with ThingSpeak™ to upload and visualize the data. With 
a free account, you can upload data once every 15 seconds. A paid account lets you 
upload data once per-second; look here for more info about various ThingSpeak™ 
services. 

Atlas Scientific has no business relationship with ThingSpeak™; we just like how it works. 
If you want to use a different service, modify the device as you see fit.

The CO2 sensor module has been removed to protect it during transport. Before you 
begin setting up the aquaponics kit, plug it back into position.

Setting up your Wi-Fi kit

Step 1 Connect Co2 sensor module

Warning:
Do not mix up sensor modules as each is calibrated to a specific EZO-CO2 device.

CO2 
sensor module

8 Copyright © Atlas Scientific LLC
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Because the sensor data is stored / viewed on ThingSpeak, you will need 
to setup a ThingSpeak account. Create your ThingSpeak account by clicking HERE.

Step 2 Setup a ThingSpeak Account

Your data is uploaded to ThingSpeak through a ‘Channel.’ Select New Channel

Step 3 Create a Channel

9 Copyright © Atlas Scientific LLC
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Fill out the highlighted boxes. (Be sure to click on the checkboxes to enable fields 2 – 6)
For reference, this is what we entered.

Name   
Field 1  
Field 2  
Field 3
Field 4
Field 5
Field 6
 
Scroll to the bottom of the page and click Save Channel.

Atlas Sensors
pH
DO (mg/L)
Temp (°C)
EC ( μS/cm) 
Humidity (%) 
CO2 (ppm)
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After you saved your channel settings, you will be redirected to your channel page. 
Click on API keys.

Be sure to save your Channel ID and Write API Key we are going to need these, in the 
next few steps.

Step 4 Get ThingSpeak API keys
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Step 5 Make sure your Arduino IDE libraries are up to date

Make sure you have the correct path for the Esp32 LibraryA
In the IDE, go to File > Preferences
Locate the Additional Boards Manager URLS text box.

Make sure this URL is in the textbox
https://raw.githubusercontent.com/espressif/arduino-esp32/gh-pages/package_esp32_index.json
Click OK.

12 Copyright © Atlas Scientific LLC



Update the Esp32 boardB
In the IDE, go to Tools > Board > Boards Manager

In the search bar of the Boards Manager, lookup esp32.
Update to the most recent version if you don’t already have it.

(Version 1.0.5 in not the most recent version) 

13 Copyright © Atlas Scientific LLC



Download the ThingSpeak library for Arduino

Add the EZO I2C Library

C

D

Click HERE to download the latest version of the ThingSpeak library.

Don’t unzip it!
Import the .ZIP file into your Arduino IDE.
To import the .ZIP file go to Sketch > Include Library > Add .ZIP Library

To download the Ezo_I2c library file, click HERE.

Don’t unzip it!
Import the .ZIP file to your Arduino IDE.
To import the .ZIP file go to Sketch > Include Library > Add .ZIP Library

14 Copyright © Atlas Scientific LLC

https://www.arduinolibraries.info/libraries/thing-speak
https://github.com/Atlas-Scientific/Ezo_I2c_lib


File> Examples> EZO_I2C_lib-master> Examples> IOT_kits> aquaponics_kit

Step 6 Flash the Hydroponics meter with the correct code

Select, open and adjust the code you want to use for your Wi-Fi KitA
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Fill in your Wi-Fi / ThingSpeak credentialsB
Fill in your Wi-Fi name and Password, along with the Channel ID and Write API Key to the 
code. (see step 3)

If you do not have a pump attached, you can just skip this part. The code is rather 
self explanatory. You set what parameters will trigger the pump to engage.

Setting up your pumpC
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Tools> Board> ESP32 Arduino > Adafruit Esp32 Feather

Step 7 Setting up the HUZZAH board

Set the target CPU to flashA
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Make sure the CPU settings on the Adafruit HUZZAH32 are correct.
To adjust the CPU settings, click Tools.

For reference, this is what Atlas Scientific set the CPU settings to.
(your options may not be exactly the same, just try and match them as closely as possible.
Don't forget to set the correct com port for your device.)

Adjust CPU SettingsB

Compile and uploadC

Compile and upload the code.
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Open your Arduino serial monitor.
(You must have the serial monitor set to the com port from the Adafruit HUZZAH32.)  

Set to carriage return and 9600 baud.

Step 8 See the readings

The Wi-Fi Aquaponics Meter will always attempt to connect to ThingSpeak on bootup.
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If it cannot connect to your Wi-Fi you will see this:

Entering the poll command will stop the Wi-Fi Aquaponics Meter from uploading the 
readings to thingspeak, while you debug your Wifi problems.
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Step 9 Sensor Calibration

Atlas Scientific created a list of calibration commands that are built into the library.
Type in help to see a list of commands.

The poll commandA
Send the command poll; This will let you see the readings once per second and it will stop 
uploading to ThingSpeak while you calibrate.
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Calibrate pHB

Make sure that the probe is dry before issuing this command, ec:cal,dry

Calibrate ConductivityC
When calibrating Conductivity, you must always calibrate a dry probe first.

When calibrating pH, you must always calibrate to pH 7 first.
Remove  the  soaker  bottle  and  rinse  off  the  pH  probe.  Remove  the  top  of  the  pH  
7.00 calibration solution pouch. Place the pH probe inside the pouch and let the probe sit 
in the calibration solution until the readings stabilize. This will take about 1 – 2 mins.

Rinse off the probe and repeat this process for both pH 4.00 and pH 10.00.

Send

6.917
7.126
7.223
7.225
7.225
7.225
7.225
ph:cal,mid,7

Unstabilized

Stabilized

Once the readings have stabilized, 
issue the Mid point calibration 
command. ph:cal,mid,7

1 − 2 mins

ASPH7P
ASPH7P

After
Calibration

After 20 mins, the calibration solution inside an 
open pouch is no longer considered accurate.

Dispose of the unused solution, after calibration.
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Once the dry calibration has been completed, place the probe into a small cup of the 
12,880µS calibration solution. Shake the probe to make  sure  you  do  not  have  trapped  
air  bubbles  in  the  sensing  area.  You  should  see  readings that are off by 1 – 40% from 
the stated value of the calibration solution. Wait for readings to stabilize.

1 5 10 15 20 25 30

1 5 10 15 20 25 30

A
B
C
D
E

F
G
H
I
J

A
B
C
D
E

F
G
H
I
J

A
B
C
D
E

F
G
H
I
J

“Cal,dry”

25°C / 77°F+/- 5

1,413µS

°C

5 41 896

10 50 1,020

15 59 1,147

20 68 1,278

25 77 1,413

°F °C

30 86 1,548

35 95 1,711

40 104 1,860

45 113 2,009

50 122 2,158

°F

Conductivity
Solution

KCl
125ml

Atlas-Scientific.com/msds.html

TM

µS/cm µS/cm

8 5 7 4 3 4 0 0 5 0 3 9

Atlas
Scientific

1 5 10 15 20 25 30

1 5 10 15 20 25 30

A
B
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E

F
G
H
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J

A
B
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D
E

F
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Atlas
Scientific

check probe connection,
you cannot calibrate to 0.

12,880µS

7,728µS – 18,032µS

12,880µS

0.00µS

12,880µS

7,728µS – 18,032µS

12,880µS

0.00µS

Trapped air in sensing 
area (shake to remove)

12,880μS 12,880μS

Send

16,247
15,491
14,053
13,756
13,756
13,756
13,756
ec:cal,low,12880

Unstabilized

Stabilized
Once the readings stabilize, issue the low point 
calibration command. ec:cal,low,12880  
(Readings will NOT change)

Rinse off the probe before calibrating to the high point. Pour a small amount of the 80,000µS 
calibration solution into a cup. Shake the probe to remove trapped air. Again, the readings 
may be off by 1 – 40% Wait for readings to stabilize.

Send

51,674
53,826
55,193
56,493
56,493
56,493
56,493
ec:cal,high,80000

Unstabilized

Stabilized
Once the readings stabilize, issue the high point 
calibration command. ec:cal,high,80000 
(Readings will change, calibration complete).
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Calibrate Dissolved OxygenD
Let the Dissolved Oxygen probe sit, exposed to air until the readings stabilize. (small 
movement from one reading to the next is normal).

Send

15.03
14.45
14.08
13.95
13.95
13.95
13.95
do:cal

Unstabilized

Stabilized
Once the readings have stabilized, 
issue the calibration command. 
do:cal

5 − 30 sec5 − 30 sec

After calibration is complete, you should see readings between 9.09 – 9.1X mg/L.
(only if temperature, salinity and pressure compensation are at default values)

24 Copyright © Atlas Scientific LLC



100 °C

Calibrating the PT-1000 temperature probe is not required. However, if you want to, 
a simple method to calibrate the probe is to place the PT-1000 into boiling water. Then 
issue command rtd:cal,t

Calibrate TemperatureE

Elevation in meters Boiling point

305
229
152

76
0

-76
-152

98.9
99.2
99.5
99.7
100
100.3
100.5

°C
°C
°C
°C
°C
°C
°C

Calibration Complete
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Step 10

Setup Complete!

Almost done!

Once you are finished with calibration, issue the datalog command to resume taking a 
reading every 15 seconds and uploading it to thingspeak.

To see the data on your phone, download the ThingSpeak app.
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